Введение в конфигурирование 1Cv8 - Основные объекты


Конструктор запросов, конструктор выходных форм - часть 2


В результате конструктор создаст выходную форму, пропишет необходимые процедуры (как это делается указываем на последней закладке конструктора форм).

В   результате   работы   конструктора   в   модуле   формы   появилась следующая процедура:

Процедура СформироватьНажатие (Элемент) ТабДок = Новый ТабличныйДокумент;

 

ОтчетОбъект. Закупки (ТабДок);

 

ТабДок. ТолькоПросмотр = Истина;

 

ТабДок. ОтображатьСетку = Ложь;

 

ТабДок. ОтображатьЗаголовки = Ложь;

 

ТабДок. Показать ();

 

КонецПроцедуры

В модуле отчета:

Процедура Закупки (ТабДок) Экспорт Макет = ПолучитьМакет (" Закупки");

 

Запрос = Новый Запрос;

 

Запрос. Текст = "ВЫБРАТЬ |            Приходная Товары. Номенклатура КАК Номенклатура, |            ПриходнаяТовары. Номенклатура. Представление, |            СУММА (ПриходнаяТовары. Количество) КАК Количество, СУММА (ПриходнаяТовары. Сумма) КАК Сумма, Приходная. Контрагент КАК Контрагент, Приходная. Контрагент. Представление |ИЗ |            Документ-Приходная. Товары КАК ПриходнаяТовары |                         ЛЕВОЕ СОЕДИНЕНИЕ Документ. Приходная КАК Приходная |                         ПО Приходная Товары. Ссылка = Приходная. Ссылка

|СГРУППИРОВАТЬ ПО ПриходнаяТовары. Номенклатура, Приходная. Контрагент

!

|ИТОГИ ПО ОБЩИЕ";

 

Результат = Запрос. Выполнить ();

 

ОбластьЗаголовок = Макет. ПолучитьОбласть (" Заголовок");

 

ОбластьПодвал = Макет. ПолучитьОбласть ("Подвал");

 

ОбластьШапкаТаблицы = Макет. ПолучитьОбласть ("ШапкаТаблицы");

 

ОбластьПодвалТаблицы=Макет. ПолучитьОбласть ("ПодвалТаблицы");

 

ОбластьОбщийИтог = Макет. ПолучитьОбласть ("ОбщиеИтоги");


ОбластьДетали = Макет. ПолучитьОбласть ("Детали");

 

ТабДок. Вывести (ОбластьЗаголовок);

 

ТабДок. Вывести (ОбластьШапкаТаблииы);

 

ВыборкаОбшийИтог = Результат. Выбрать (ОбходРезультатаЗапроса. ПоГруппировкам);

 

ВыборкаОбшийИтог. Следуюший ();

                     

// Обший итог ОбластьОбщийИтог. Параметры. Заполнить (ВыборкаОбшийИтог);

 

ТабДок. Вывести (ОбластьОбщийИтог);

 

ВыборкаДетали = ВыборкаОбщийИтог. Выбрать ();

 

Пока ВыборкаДетали. Следуюший () Цикл ОбластьДетали. Параметры. Заполнить (ВыборкаДетали);

 

ТабДок. Вывести (ОбластьДетали);

 

КонецЦикла;

 

ТабДок. Вывести (ОбластьПодвалТаблицы);

 

ТабДок. Вывести (ОбластьПодвал);

 

КонецПроцедуры

 

Практикум № 25__________________________________________

1. Создайте с помощью конструктора отчет по продажам товаров. В нем после установки периода должна содержаться следующая информация: какой покупатель, какие товары, в каком количестве и на какую сумму закупал.

2.   Модифицируйте созданный вами отчет.  Необходимо добавить возможность выбора контрагента. В случае, если контрагент не выбран,    отчет    должен    предоставлять    информацию   по   всем контрагентам.

3.  Создайте отчет, который позволяет смотреть продажи товаров. Но  в  нем  помимо  сумм  продажи  фигурирует  себестоимость  и прибыль.   Себестоимость  единицы  товара  берется   из реквизита «ЦенаПокупки» справочника «Номенклатура»




- Начало -  - Назад -  - Вперед -



Книжный магазин