Введение в конфигурирование 1Cv8 - Основные объекты

Текстиль официальный сайт Иваново смотрите на www.ивтек𚦉.рф. |

Использование диаграмм


Для ознакомления с возможностями использования диаграмм рассмотрим отчет «Диаграмма». При создании данного отчета его необходимо изменить (он должен отображать суммы по группам номенклатуры)

У отчета определены два реквизита: НачПериода (тип «Дата»), КонПериода (тип «Дата»). В диалоге определен элемент управления «Диаграмма» (имя «эфДиаграмма»). Диалог формы при этом имеет следующий вид:

Модуль формы содержит описание следующих процедур:

Процедура КнопкаСформироватьНажатие (Элемент) ЭлементыФормы. эфДиаграмма. КоличествоСериЙ = 0;

 

Элементы Формы, эфДиаграмма. Количество Точек = 0;

 

ВыполнитьОтчет (ЭлементыФормы. эфДиаграмма);

 

ВыбТипДиафаммы = ЭлементыФормы. эфДиаграмма. ТипДиаграммы;

 

КонецПроцедуры

Процедура ВыбПериодНажатие (Элемент) НастройкаПериода = Новый НастройкаПериода;


НастройкаПериода. УстановитьПериод (НачПериода,     ?(КонПериода='0001-01-01', КонПериода, КонецДня (КонПериода)));


НастройкаПериода. РедактироватьКакИнтервал = Истина;

 

НастройкаПериода. РедактироватьКакПериод = Истина;

 

НастройкаПериода. ВариантНастройки = ВариантНастройкиПериода. Период;

 

НастройкаПериода. Редактироватъ ();

 

НачПериода = НастройкаПериода. ПолучитьДатуНачала ();

 

КонПериода = НастройкаПериода. ПолучитьДатуОкончания ();

 

КонецПроцедуры

Процедура ПолеВыбораПриИзменении () ЭлементыФормы. эфДиаграмма. ТипДиаграммы = ВыбТипДиаграммы;

 

КонецПроцедуры

ЭлементыФормы. ВыбТипДиаграммы. СписокВыбора. Добавить (ТипДиаграммы. Круговая, "Круговая");

 

ЭлементыФормы. ВыбТипДиаграммы. СписокВыбора. Добавить (ТипДиаграммы. КруговаяОбъемная, "Круговая объемная");

 

ЭлементыФормы. ВыбТипДиаграммы. СписокВыбора. Добавить (ТипДиаграммы. Гистограмма, "Гистограмма");

 

ЭлементыФормы. ВыбТипДиаграммы. СписокВыбора. Добавить (ТипДиаграммы. ГистограммаОбъемная, "Гистограмма объемная");

 

ЭлементыФормы. ВыбТипДиаграммы. СписокВыбора. Добавить (ТипДиаграммы. ГистограммаСНакоплением, "Гистограмма с накоплением");

 

ЭлементыФормы. ВыбТипДиаграммы. СписокВыбора. Добавить (ТипДиаграммы. ГистограммаСНакошхениемОбъемная, "Гистограмма с накопл. объемная");


 

Модуль объекта содержит описание следующей процедуры:

 

Процедура ВыполнитьОтчет (эфДиаграмма) Экспорт Запрос = Новый Запрос;

 

ТекстЗапроса = "ВЫБРАТЬ |Номенклатура, Номенклатура. Наименование НаименованиеНоменклатуры, |КоличествоОборот Количество, СуммаОборотСумма |ИЗ РегистрНакопления. Продажи. Обороты (&ПериодС, &ПериодПо„) |УПОРЯДОЧИТЬ ПО Номенклатура. Наименование |ИТОГИ Сумма (Количество), Сумма (Сумма) ПО Номенклатура ТОЛЬКО ИЕРАРХИЯ

I";


Запрос. Текст = ТекстЗапроса;

 

Запрос. УстановитьПараметр ("ПериодС", НачПериода);

 

Запрос. УстановитьПараметр ("ПериодПо", КонПериода);


РезультатЗапроса = Запрос. Выполнить ();

 

эфДиаграмма. Обновление = Ложь;

 

эфДиаграмма. КоличествоТочек = 1;

 

эфДиаграмма. Точки [0]. Текст = "Сумма";


ВыборкаОсновная = РезультатЗапросаВыбратъ (ОбходРезультатаЗапроса. ПоГруппировкам);

 

Пока ВыборкаОсновная, Следующий () Цикл ВыборкаДетальная = ВыборкаОсновная. Выбрать ();

 

Пока ВыборкаДетальная. Следуюший () Цикл эфДиаграмма. КоличествоСерий = эфДиаграмма. КоличествоСерий + 1;

 

эфДиаграмма. Серии [эфДиафамма. КоличествоСерий — 1]. Текст = СокрП (ВыборкаДетальная. НаименованиеНоменклатуры);

 

эфДиафамма. Серии [эфДиафамма. КоличествоСерий-1]. Расшифровка= ВыборкаДетальная. Номенклатура, эфДиаграмма. УстановитьЗначение (0, эфДиаграмма. КоличествоСерий — 1, ВыборкаДетальная. Сумма,);


КонецЦикла;

 

КонецЦикла;


эфДиаграмма. Обновление = Истина;

 

КонецПроцедуры

 




- Начало -  - Назад -  - Вперед -



Книжный магазин