Введение в конфигурирование 1Cv8 - Основные объекты


Хранилище значений


Объект предназначен для хранения значения в специальном формате. Он может быть записан в поля информационной базы, имеющие соответствующий тип. Это позволяет сохранять в информационной базе значения, тип которых не может быть выбран в качестве типа поля, например «Картинка». Большинство объектов, которые имеют неизменяемое значение, а также универсальные коллекции, могут быть преобразованы в значение «Хранилище Значения». К значению, хранящемуся в объекте, нельзя обращаться, его можно только извлечь из хранилища.

Не рекомендуется хранить в реквизитах этого типа ссылки на другие объекты информационной базы.

Для знакомства с объектом «ХранилищеЗначения» определите у справочника «ФизическиеЛица» реквизит «Фотография» (тип «ХранилищеЗначения»).

Для отображения фотографии в диалоге формы элемента определите дополнительную страницу в элементе управления «Панель», поместите на нее элемент управления «поле картинки» (имя «Фото») и две кнопки.

В модуле формы элемента необходимо прописать две процедуры:

Процедура Кнопка1Нажатие (Элемент) РежимРежимДиалогаВыбораФайла. Открытие;

 

ДиалогОткрытияФайла=Новый ДиалогВыбораФайла (Режим);

 

ДиалогОткрытияФайла. ПолноеИмяФайла="";

 

Фильтр="Все (*,*)|*,*";

 

ДиалогОткрытияФайла. Фильтр=Фильтр;

 

ДиалогОткрытияФайла. МножественныйВыборЛожь;

 

ДиалогОткрытияФаЙла. Заголовок="Выберите файлы";

 

Если ДиалогОткрытияФаЙла. Выбрать () Тогда ВыбФайл=Новый Картинка (ДиалогОткрытияФайла. ПолноеИмяФайла);

 

Хран=Новый ХранилишеЗначения (ВыбФаЙл);

 

Фотография=Хран;

 

КонецЕсли;

 

КонецПроцедуры

Процедура Кнопка2Нажатие (Элемент) ЭлементыФормы. Фото. Картинка=Фотография. Получить ();

 

КонецПроцедуры

Проверьте работоспособность данного механизма.




- Начало -  - Назад -  - Вперед -