Введение в конфигурирование 1Cv8 - Основные объекты


Фильтрация результатов запроса - часть 3


/p>

Полное внешнее соединение. В результат запроса войдут как записи, для которых выполнялось условие соединения, так и записи, полученные из «не вошедших» данных из обеих таблиц.

Ручка

Шт.

Ручка

банка

Вилка

Гр,

Карандаш

Null

Null

Кг.

В любом случае, даже в результате использования полного внешнего соединения не получается полная комбинация значений. (В случае полного соединения добавляются записи, не удовлетворяющие условию, а не все возможные их комбинации).

В качестве примера использования соединений рассмотрим нижеследующий текст запроса:

Выбрать

Контр. Наименование Как Контрагент, Контакт. Наименование ФИО, Контакт. Телефон Из

ВыборкаДетальная. Номенклатура, эфДиаграмма. УстановитьЗначение (0, эфДиаграмма. КоличествоСерий — 1, ВыборкаДетальная. Сумма,);


КонецЦикла;

 

КонецЦикла;


эфДиаграмма. Обновление = Истина;

 

КонецПроцедуры




- Начало -  - Назад -  - Вперед -